Fragen über die Videos ab 5.1

Videos von HomepageHelfer und Diskussionen dazu.

Moderatoren: goefi-chiangmai, Jasko

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 22:25

Meine Bilddatei ist als png abgespeichert.
Wenn ich den Teil //$Bilddatei = imagecreatefrompng('hintergrund1.png'); auskommentiere, dann erscheint nur die folgende Fehlermeldung, die nicht gerade hilfreich ist: Die Grafik kann nicht angezeigt werden, weil sie Fehler enthält. Auch das Ändern der Bilddatei und des Codes führt zu keiner Lösung.



Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3129
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 22:42

OK gut, nun kommentire wieder, den selben Code aus (wie unter Punkt 2), und kommentiere auch diese Linie aus:
header('Content-type: image/jpeg');

Nun wirst du eine Reihe von Fehlern und Warnungen bekommen. Kopiere diese und poste sie hier mal schauen was die sagen.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 22:49

Ich habe jetzt folgendes auskommentiert:

//header('Content-type: image/jpeg');

und

//$Bilddatei = imagecreatefrompng('hintergrund1.png');

Ist das so richtig?
Kommentiere ich dies aus, werden mir keine Fehlermeldungen angezeigt. Die Seite wird komplett weiß.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 22:49

Ach ja. Ich hab die Bilddatei umbenannt und das auch alles richtig abgespeichert, da ich ja eine neue weiße Datei erstellt habe.

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3129
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 22:59

Ist OK mit dem umbenennen, aber da geht wircklich etwas schief. wenn die Bilddatei fehlt, also die Variable, die aber darunter genutzt wird muss wenigstens eine Warnung kommen.

Mann kein "Boneneintopf" machen ohne vorher die Bohnen zu haben,da müssen die Alarmglocken leuten. Upps vieleicht ein wenig zu viel Metafern, aber du verstehst mich schon :D ;)

Versuch mal XAMPP als Server, es gibt eine Portable version, (http://sourceforge.net/projects/xampp/f ... ows/1.8.0/) hier die USB lite (zip) version (mit php 5.4), und versuch dann dort den Captcha zu implementieren.

Hier gibt es paar infos zu xampp
viewtopic.php?f=141&t=4854

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 23:02

Ich weiß nicht, ob ich Xampp einfach benutzen darf, da ich ja bestimmt den Server von der Uni nehmen muss. Aber trotzdem vielen Dank für deine Hilfe. Vielleicht frage ich bei meinem Dozenten noch mal nach, ob ich theoretisch Xampp benutzen darf.

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3129
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 23:05

Klar ist kein Problem, das einzige was ich damit sicher stellen wollte ist, ob es wircklich an den Einstellungen des Servers liegt. Vieleicht kannst mir einen Link schicken von wo du den Server hast, damit ich es mal versuche auf meinem Rechner.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 23:23

Wir nutzen FileZilla, so wie du in dem Video und unser Server ist irgendwie von der Uni. Das ist der Link dazu: mewi.wi2.phil.tu-bs.de
Allerdings glaube ich, dass du da so nicht einfach rein kannst. Du müsstest dich authentifizieren können. Dazu müsste ich dir bestimmt mega illegal meine Daten geben. :D

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3129
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 23:32

Na dann passt das schon, frage einfach mal den Dozenten, woran das liegen könnte. Bei mir läuft der Code auf drei verschiedenen Servern, mit drei verschiedenen php Versionen problemlos, warum das bei dem UNI Server nicht geht...

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 23:35

Okay. Trotzdem vielen Dank für deine Hilfe. :)


Zurück zu „PHP Schule“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast