Fragen über die Videos ab 5.1

Videos von HomepageHelfer und Diskussionen dazu.

Moderatoren: goefi-chiangmai, Jasko

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3125
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Fragen über die Videos ab 5.1

Beitragvon Jasko » So 12. Jul 2015, 18:16

Hier bitte die Fragen zu den Videos mit der anfangs Nummer 5.

Hier ist schon das erste Video: Eigenes Captcha - zufälliger Text

in dieser Reiehe werde ich noch andere Arten von Captchas vorstellen und hier zur gegebenen Zeit vorstellen.

LG



Benutzeravatar
moni
Moderator
Moderator
Beiträge: 7260
Registriert: Mo 16. Nov 2009, 20:56
Mein Vorname: Monika
Wohnort: Borken
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon moni » So 12. Jul 2015, 21:39

Hallo Jasko ..danke dir für das Video ...habe das schrit für schritt verfolgt und auch direkt an meinen Editor getippt und webspace geladen ..leider habe ich was falsch gemacht ...
hab dir ein PN gesendet ...
an sich , besonders da erste teil vom Video hört sich sehr logisch an und erklärt damit wie an sich funktioniert so ne captcha , Es ist schon sehr interessant mit den Bild und auch verschiedenen ungewöhnlichen Schrift arten und warum man das so macht !
in die zweite Hälfte vom Video, da muss man schon gute php Kenntnissen haben und so was aus den Kopf erstellen zu können, doch für einen Laie reicht es schon wenn es erklärt bekommt wo was liegt und was zu bedeuten ist ! das ist schon große Hilfe !
hast wieder mal sehr gute Arbeit geleistet ... Sage einfach Dankeschön !

---------------------------------------------
Nachtrag

Fehler behoben und sieht schon mal gut aus :)

http://www.blicke1.de/captscha/captcha.php
Viele Grüße ...Monika




Top 100

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Do 28. Jan 2016, 22:42

Lieber Jasko,

erst mal ein ganz großes Dankeschön für dein YouTube-Video (über welches ich auch erst auf dieses Forum gestoßen bin).
Zur Zeit programmiere ich eine Webseite und habe dazu auch ein Gästebuch erstellt. Nachdem ich damit durch war, bin ich auf die Idee gekommen das Gästebuch mit einem Captcha vor Spam zu schützen. Da ich selber noch nicht sonderlich ausgereifte php-Kenntnisse aufweisen kann, habe ich nach Hilfe im Internet gesucht und welche gefunden. Dein Video! :) Allerdings scheine ich einen Fehler gemacht zu haben. Lade ich die Dateien im FileZilla hoch und öffne sie auf meinem Server, dann wird lediglich das Hintergrundbild angezeigt. Jedoch kein Code. Wahrscheinlich ist es nur ein dämlicher kleiner Fehler, aber ich kann ihn einfach nicht finden. Weißt du, oder jemand anderes aus dem Forum woran das liegen könnte? Es wäre super, wenn mir jemand helfen würde. Wenn sich jemand bereit erklärt, könnte ich auch mein Script versenden.
Es sei denn das macht zu große Umstände.

Liebe Grüße,

Kristin

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3125
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Do 28. Jan 2016, 22:53

Hast du den Code selbst geschrieben oder unter dem Video kopiert. Ein häufiger Fehler ist den php AnfangsTag nicht an aller erster stelle zu setzen und ein Fehler wird generiert. check mal ob das der Fall ist?

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Do 28. Jan 2016, 23:00

Erst mal danke, dass du mir so schnell eine Rückmeldung geben konntest. :)
Alsoo:
Ich habe mir das Video angesehen und zeitlich nachgemacht, was du vorgemacht hast. Vielleicht ist dabei ein Fehler entstanden, den ich jetzt irgendwie nicht mehr finden kann. Vielleicht finde ich ihn ja morgen Früh. Wie du schon meintest, sieht es am nächsten Tag vielleicht ganz anders aus.
Und ich habe php zu Beginn meines Scripts geöffnet und am Ende geschlossen. Das ist es also nicht. :(

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3125
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Do 28. Jan 2016, 23:12

Das wird schon, unter dem Video hier im Forum ist der Code noch einmal angegeben, da kannst nachschauen ob etwas abweicht bei dir.

viewtopic.php?f=141&t=6442#p62589

MFG

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Do 28. Jan 2016, 23:24

Ah cool, danke. :) Das hab ich noch gar nicht gesehen. Hehe Frischling :mrgreen:

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 16:24

Oh man,
ich bin langsam wirklich am Verzweifeln. Ich verstehe nicht, warum mein Captcha nicht funktioniert. Dabei habe ich glaube ich tatsächlich alles genau so gemacht wie du. Selbst, wenn ich dein Script komplett übernehme und nur die Schriften und meinen Hintergrund (alles genau so benannt, wie in dem Video) hochlade, erscheint nur der Hintergrund aber ohne Zahlen-Buchstaben-Code. Hast du noch eine Idee woran das liegen könnte? Wahrscheinlich bin ich einfach gerade nur dämlich. :(

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3125
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 16:36

Welche php Version nutzt du denn? Könnte damit zu tun haben.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 16:47

Da musste ich gerade erst mal selber überlegen. Wir haben das Programm, Server etc. von der Uni vorgegeben bekommen. Ich hab jetzt herausgefunden, dass es diese Version sein müsste: PHP Version 5.4.4-14+deb7u10
Kann das richtig sein oder benötigst du andere Daten?


Zurück zu „PHP Schule“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast